After Heartbleed And Shellshock…..It’s Now Poodle?

The world is getting more and more unsafe it seems. Google security engineers have uncovered a major vulnerability dubbed Poodle in Web encryption standard SSL 3.0 last November. The bug makes browsers susceptible to hacking, but researchers state that it is not as harmful as Heartbleed or Shellshock bugs. What? You haven’t heard of either…